<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<title>Weekend in Review: DragonCon 2022 | Review St. Louis</title>
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.reviewstl.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.reviewstl.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.reviewstl.com/feed/atom/" />
<link rel="pingback" href="https://www.reviewstl.com/xmlrpc.php" />
<div id="fb-root"></div>
<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12&appId=409213959110159&autoLogAppEvents=1';
    fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>

<meta property="og:locale" content="en_US" />
<meta property="og:type" content="" />
<meta property="og:url" content="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/" />
<meta property="og:title" content="Weekend in Review: DragonCon 2022" />
<meta property="og:description" content="" />
<meta property="og:site_name" content="Review St. Louis" />
<meta property="og:image" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta property="og:image:width" content="2392" />
<meta property="og:image:height" content="1406" />
<meta property="fb:app_id" content="409213959110159" />
<meta itemprop="description" content="" />
<meta itemprop="image" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/" />
<meta name="twitter:title" content="Weekend in Review: DragonCon 2022" />
<meta name="twitter:description" content="" />
<meta name="twitter:image" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta name="twitter:creator" content="@reviewstlouis" />
<meta name="twitter:site" content="Review St. Louis" />

<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Review St. Louis &raquo; Feed" href="https://www.reviewstl.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Review St. Louis &raquo; Comments Feed" href="https://www.reviewstl.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Review St. Louis &raquo; iCal Feed" href="https://www.reviewstl.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Review St. Louis &raquo; Weekend in Review: DragonCon 2022 Comments Feed" href="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.reviewstl.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.reviewstl.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='embedpress_blocks-cgb-style-css-css' href='https://www.reviewstl.com/wp-content/plugins/embedpress/Gutenberg/dist/blocks.style.build.css?ver=1661615067' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='aalb_basics_css-css' href='https://www.reviewstl.com/wp-content/plugins/amazon-associates-link-builder/css/aalb_basics.css?ver=1.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='embedpress-css' href='https://www.reviewstl.com/wp-content/plugins/embedpress/assets/css/embedpress.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.reviewstl.com/wp-content/plugins/wp-event-aggregator/assets/css/font-awesome.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-event-aggregator-front-css' href='https://www.reviewstl.com/wp-content/plugins/wp-event-aggregator/assets/css/wp-event-aggregator.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='novelty-font-opensans-css' href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,600,700,800' type='text/css' media='all' />
<link rel='stylesheet' id='novelty-font-custom-css' href='https://fonts.googleapis.com/css?family=Suravaram' type='text/css' media='all' />
<link rel='stylesheet' id='novelty-css-bootstrap-css' href='https://www.reviewstl.com/wp-content/themes/novelty-child/css/bootstrap.css' type='text/css' media='all' />
<link rel='stylesheet' id='novelty-css-awesome-css' href='https://netdna.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='novelty-css-main-css' href='https://www.reviewstl.com/wp-content/themes/novelty-child/css/style.css?ver=1.01' type='text/css' media='all' />
<link rel='stylesheet' id='novelty-css-root-css' href='https://www.reviewstl.com/wp-content/themes/novelty-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.reviewstl.com/wp-includes/css/dashicons.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='https://www.reviewstl.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=14.1.2' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var tesla_ajax = {"url":"https:\/\/www.reviewstl.com\/wp-admin\/admin-ajax.php","nonce":"504268a24c"};
tesla_ajax.actions = {novelty_team:{},
novelty_skills:{},
novelty_toggle:{},
};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/plugins/embedpress/assets/js/pdfobject.min.js?ver=3.5.0' id='embedpress-pdfobject-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/tesla_framework/static/js/holder.js' id='tesla-image-holder-js'></script>
<script type='text/javascript' id='__ytprefs__-js-extra'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.reviewstl.com\/wp-admin\/admin-ajax.php","security":"a757dff7ce","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.reviewstl.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/www.reviewstl.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs__\",\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"14.1.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","facade_mode":"","not_live_on_channel":"","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=14.1.2' id='__ytprefs__-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4' id='ga-external-tracking-js'></script>
<link rel="https://api.w.org/" href="https://www.reviewstl.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.reviewstl.com/wp-json/wp/v2/posts/72397" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.reviewstl.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.reviewstl.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.2" />
<link rel="canonical" href="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/" />
<link rel='shortlink' href='https://www.reviewstl.com/?p=72397' />
<link rel="alternate" type="application/json+oembed" href="https://www.reviewstl.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.reviewstl.com%2Fweekend-in-review-dragoncon-2022%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.reviewstl.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.reviewstl.com%2Fweekend-in-review-dragoncon-2022%2F&#038;format=xml" />
<meta property="fb:app_id" content="409213959110159" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.reviewstl.com"><link rel="alternate" href="https://www.reviewstl.com/wp-json/tribe/events/v1/" /><script type="text/javascript">var ajaxurl = 'https://www.reviewstl.com/wp-admin/admin-ajax.php';</script><link rel="icon" href="https://www.reviewstl.com/wp-content/uploads/2020/06/ReviewSTL-thumb-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://www.reviewstl.com/wp-content/uploads/2020/06/ReviewSTL-thumb-300x300.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.reviewstl.com/wp-content/uploads/2020/06/ReviewSTL-thumb-300x300.jpg" />
<meta name="msapplication-TileImage" content="https://www.reviewstl.com/wp-content/uploads/2020/06/ReviewSTL-thumb-300x300.jpg" />

<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-5208020-1', 'auto');
 
	ga('send', 'pageview');
</script>
<style type="text/css" id="wp-custom-css">
			.entry-content-details {
	
	margin-bottom: 10px !important;
	
}

#wpdevar_comment_1 {

font-family: open sans,Helvetica,Arial,sans-serif !important;	
color: #000000;
font-weight: 800 !important;
}

.ose-youtube.responsive {
	
	padding-bottom: 5px !important;
	
}


.embedpress-wrapper {

	padding-bottom: 5px !important;
	
}
		</style>
<style type="text/css">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</style>


<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="Review St. Louis" />
<meta property="og:title" content="Weekend in Review: DragonCon 2022" />
<meta property="og:url" content="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Welcome, friends, to another tale of the trials and tribulations in a strange, funny, and magical place called DragonCon! I’m writing this recap almost a week post-con and have had my brain microwaved by Covid fever for the past few days. It may get a little weird… But hey, DragonCon is the home of" />
<meta property="og:image" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta property="og:image:url" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta property="og:image:secure_url" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta property="article:published_time" content="2022-09-14T16:06:39-05:00" />
<meta property="article:modified_time" content="2022-09-14T16:15:22-05:00" />
<meta property="og:updated_time" content="2022-09-14T16:15:22-05:00" />
<meta property="article:section" content="Convention Reviews" />


<meta name="twitter:title" content="Weekend in Review: DragonCon 2022" />
<meta name="twitter:url" content="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/" />
<meta name="twitter:description" content="Welcome, friends, to another tale of the trials and tribulations in a strange, funny, and magical place called DragonCon! I’m writing this recap almost a week post-con and have had my brain microwaved by Covid fever for the past few days. It may get a little weird… But hey, DragonCon is the home of" />
<meta name="twitter:image" content="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@reviewstlouis" />




<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4930068763889019" crossorigin="anonymous"></script>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-72397 single-format-standard tribe-no-js">

<div class="header">
<div class="container">
<div class="row">
<div class="col-md-4">
<div class="logo">
<a href="https://www.reviewstl.com">
<img src="https://reviewstl.com/wp-content/uploads/2017/02/ReviewSTL-Logo-2017.png" alt="logo" /> </a>
</div>
</div>
<div class="col-md-4">

</div>
<div class="col-md-4">
<ul class="header-socials">
<li><a class="header-socials-facebook" href="https://www.facebook.com/reviewstl/"><i class="fa fa-facebook"></i></a></li>
<li><a class="header-socials-twitter" href="https://twitter.com/reviewstlouis"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
</div>
</div>
<div class="menu site-bg-color">
<div class="container">
<form class="header-search" action="https://www.reviewstl.com/">
<input type="submit" id="searchsubmit" value="" class="header-search-button" />
<input type="text" value="" name="s" id="s" class="header-search-line" placeholder="Search ..." />
</form>
<div class="responsive-menu">Menu</div>
<div class="menu-main-nav-container"><ul id="menu-main-nav" class="menu"><li id="menu-item-52144" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52144"><a href="/">Home</a></li>
<li id="menu-item-52142" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52142"><a href="https://www.reviewstl.com/category/reviews/movie-reviews/">Movies</a></li>
<li id="menu-item-52143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52143"><a href="https://www.reviewstl.com/category/reviews/live-theater-reviews/">Live Theatre</a></li>
<li id="menu-item-62764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62764"><a href="https://www.reviewstl.com/category/concerts/">Music</a></li>
<li id="menu-item-62763" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62763"><a href="https://www.reviewstl.com/category/reviews/videogame-reviews/">Videogames</a></li>
<li id="menu-item-52255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52255"><a href="/event/">STL Events</a></li>
</ul></div> </div>
</div>
</div>
 
<div class="content">
<div class="container">
<div class="row">
<div class="col-md-8">
<h4 class="category-page site-text-color"><a href="https://www.reviewstl.com/category/reviews/convention-reviews/" rel="category tag">Convention Reviews</a></h4>
<div class="blog-entry">
<div class="entry-header">
<h1>Weekend in Review: DragonCon 2022</h1>
</div>
<div class="entry-cover">
<img width="2392" height="1406" src="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082.jpg 2392w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082-300x176.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082-1024x602.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082-768x451.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082-1536x903.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220902_2244401082-2048x1204.jpg 2048w" sizes="(max-width: 2392px) 100vw, 2392px" /> </div>
<div class="entry-content-details">

<span>Posted:</span> September 14, 2022 at 4:06 pm &nbsp; / &nbsp; by <a href="https://www.reviewstl.com/author/steveh/" title="Posts by Steve Heineman" rel="author">Steve Heineman</a> &nbsp; / &nbsp; <a href="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/">comments (0)</a>
<div class="entry-content-tags">tags: <a href="https://www.reviewstl.com/tag/cosplay/" rel="tag">cosplay</a>, <a href="https://www.reviewstl.com/tag/dragoncon/" rel="tag">Dragoncon</a>, <a href="https://www.reviewstl.com/tag/dragoncon-2022/" rel="tag">DragonCon 2022</a></div>
<br><div class="fb-like" data-layout="standard" data-action="like" data-size="small" data-show-faces="false" data-share="true"></div>
</div>
<div class="entry-content">
<p>Welcome, friends, to another tale of the trials and tribulations in a strange, funny, and magical place called DragonCon! I’m writing this recap almost a week post-con and have had my brain microwaved by Covid fever for the past few days. It may get a little weird… But hey, DragonCon is the home of the weird!</p>
<h2><strong>Wednesday</strong></h2>
<p>In the wake of last year’s event, the Calamity Crew decided now would be the time to splurge for the whole con rather than start with the mad Thursday rush. So many of our friends show up on Wednesday anyway, so we dropped the extra money to go for it. And if you’re on the fence about doing this yourself, I would say it is ABSOLUTELY worth it. Thursday feels like an intense stress rush from the moment you get into Atlanta until the moment you go to bed that night… or Friday morning if you’re like me.</p>
<p>Showing up on Wednesday allowed us some time to breathe after the drive down. My car, including James, Keesha (@kuudere.kitten), and myself, certainly needed it after driving nearly 9 hours through countless construction sites. Justin (@justbryyce) showed up earlier in the day, so he had already checked into our room as well. All we had to do was wait for the valet and bring up our bags. Within moments of arrival, we were ambushed by a gang of our North Carolina con family. Stormy (@tiny_villain_cosplay) and Ted (@tengutri), along with Sergei (@sergeikay) and Nathan (@nako.ninja), all barged in for hugs and revelry as we celebrated our “1st floor status”.</p>
<p>In addition to showing up a day early, we also dropped extra money on one of the low-level rooms. So all weekend, we were able to use our room as an easy access base of operations. And I do mean EASY. We went almost the entire weekend without waiting on elevators. Whole lot of stairs though. I think I walked more stairs that weekend than any other DragonCon. Still, very much worth it.</p>
<p>Justin followed our first NC con friend group to check out the photo booth setup in Stormy and Ted’s room. By the time I finished getting unpacked, another group of friends showed up to kick off the weekend. One of our OG North Carolina friends Jenn (@jenna_say_what) was already on her second costume of the weekend. She brought a few familiar faces with her, including award-winning horror director Chris Moore (@ilikefilms) and our social network of a friend Christian (@shadowkillion). With their arrival, it became very apparent that DragonCon was upon us!</p>
<p>After meeting a few of our Saint Louis friends along the balcony, including Chris and Mike (@carrbrosprops), Niki (@fiestyhufflepuff), and Art (@apitch85), we helped our new roommate Sammie (@bonedaddyds) get settled in our room. It seems like every year we do DragonCon, we gamble on at least one roommate. Luckily all of them have been good, but Sammie absolutely knocked it out of the park. ESPECIALLY for her first DragonCon. She meshed so well with the Calamity Crew. We’ll definitely be seeing her more in our convention adventures.</p>
<p>The final task of the day was to help Keesha get settled. Through help from mutual friends, she was set up with a spot in a room with our good friend Brittani Ginoza! (@ginozacostuming) Keesha and I played the first elevator waiting game of the con, going up to the 20th floor to Ginoza’s room. We were immediately assaulted by a much more humid space. Unfortunately the AC wasn’t working nearly as well in their room as in the ones down on the first floor. That didn’t stop the excitement though. Brittani unpacked a flurry of convention swag to give away, most of which she made herself. She gave me and Keesha our first badge ribbons of the weekend. There were plenty more to come, but this particularly naughty one certainly got the most attention.</p>
<p>As everyone settled into their respective living spaces for the weekend, I couldn’t help noticing that Wednesday night at DragonCon felt like a Friday night at most other cons. The con hadn’t officially started yet, but there were already so many people! There may not have been any official parties happening, but we made due and celebrated until the early hours of the morning.</p>
<p><a href="#photo-gallery">Check out our DragonCon 2022 photos</a>.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_122-1024x683.jpg" alt="" class="wp-image-72415" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_122-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_122-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_122-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_122-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_122.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<h2><strong>Thursday</strong></h2>
<p>This was my first year experiencing the entire Thursday of DragonCon. I was happy to take it slow, but I didn’t know certain things about the weekend. First, press registration didn’t open until 2pm so Justin and I would have to wait to get our badges. Second, the vendor hall wasn’t open yet! I had planned to go as early as I could to avoid the wait of more crowded days because I needed something I could only get from there. The face paint intended for my biggest cosplay of the weekend, my biggest cosplay ever, needed a special activating spray. Jenn recommended this particular face paint, saying it works extremely well for her various Harley Quinn cosplays. When she told me the vendor was at the convention, I hoped I could get a bottle of the activating spray. Unfortunately, that didn’t work out because the vendor hall wasn’t open on Thursday. But as you’ll see in Friday’s recap, Malak still worked out just fine.</p>
<p>We started off the day with Keesha joining Justin and I for a walk over to the Metro Diner to meet Sammie for brunch. After their dining room was closed last year, I was extremely happy to get back into Metro for a meal again. Hearty breakfasts and some insanely delicious chili cheese fries filled us up for the first day of the con. Keesha left to go join the line for badges while Justin, Sammie, and I went back to our hotel room to prepare for something I have never done at a con before… weightlifting!</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_3-1024x683.jpg" alt="" class="wp-image-72408" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_3-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_3-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_3-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_3-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_3.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>The Carr brothers met us on the balcony overlooking the Marriott atrium. We all went down to the gym for some nerd fitness. All four of them are regular lifters, with me being the relative newbie. I also had to skip my previous week’s workouts, so obviously it was a bit of a struggle to keep up. After about an hour of exercise, we realized there was a photoshoot happening at the Marriott pool! I had heard about the pool shoots, but had never seen one here before. I was immediately bummed I didn’t have my camera with me to get a few shots of the cosplayers. There’s a chance we might try to bust out some swimsuit costumes for next year though!</p>
<p>After the workout came the blurry point in the day. Once Justin and I got our press passes, it was a mad dash of meeting a TON of people we’ve known from years past. Wonderful friends like the greatly talented cosplayer and photographer Annie Graves (@anniegraves.cosplay), who was finally back at DragonCon since her first attendance back in 2019! As Annie stated beautifully over the weekend, being back to a place that lets you feel free to be weird, it feels like coming home.</p>
<p>I always feel like a piece of taffy in these situations, pulled and stretched from group to group. In so many cases, I end up forgetting to take photos because I’m just too excited to even think of the camera! This was the first DragonCon where I set the camera down for an entire day too. I made sure to get a few pictures on my phone as well, but I didn’t get nearly as many as I usually get. The social pinballing, coupled with the workout from earlier, wore me down to the point where I needed to recharge for the night’s festivities. It was time for me to do what I always do at DragonCon… take a big nap before a party!</p>
<p>Just about everyone I know makes plans for the Bunny Hutch party. Not only to attend, but to come with costumes themed for the occasion. The first year I went, I don’t think I even wore a costume. Last year, I wore the vault suit. This year, I finally put together a costume that worked with the theme, using things I already owned. Only this year did it even occur to me to wear just a few select pieces of Hufflepuff house gear. With shorts, a tie, and a bathrobe, I’m a Hufflebuff! A Harry Potter costume isn’t necessarily my first choice, but I happened to have accumulated all of those pieces over the last few years.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_41-1024x683.jpg" alt="" class="wp-image-72411" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_41-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_41-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_41-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_41-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_41.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>Wearing way less clothes than I’ve ever been used to at any con, I met up with my roomies and the rest of the STL crew to walk into the Bunny Hutch. Of course, the party did not disappoint. Great beats, good drinks, and awesome friends is the perfect way to truly kick off DragonCon. We still haven’t gotten James to cosplay at Dragon, but Justin has fully embraced the weird. The Carr brothers have definitely assisted that. Justin and our friend Brian () were cosplaying as sexy Shy Guys. It was, of course, a Carr idea, but they wouldn’t be wearing theirs until later in the weekend when all 5 of the Shy Guys were out in force.</p>
<p>My favorite part of this party might be the re-entry tickets. Being able to go to the bathroom or get some food or drinks mid-party without having to get back in line is fantastic. The line for any party in the Hilton is usually massive, so nobody wants to wait that time more than once. After going out a second time, I made a drink delivery to Keesha in her beautiful Princess Aurora bunny suit. She was still waiting out in that monster of a line with Lauren (@cheeky_cosplay) and Jill (@bodydoublecosplays) and a few others. I’m sure almost everyone can attest, waiting in line at DragonCon is best done with friends.</p>
<p>Cue another blurry montage of parties, afterparties, and after afterparties! Interject one small interaction in a movie room with friends that I was absolutely not chill enough for. Like I’ve mentioned in past reports, DragonCon goes big. Aside from the metrics to prove it, DragonCon <em>felt</em> bigger this year. Last year’s transition back into things was fun, but a bit of a bumpy start. This year was a full-blown DragonCon!</p>
<p><a href="#photo-gallery">Check out our DragonCon 2022 photos</a>.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_51-1024x683.jpg" alt="" class="wp-image-72412" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_51-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_51-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_51-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_51-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_51.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<h2><strong>Friday</strong></h2>
<p>For this year’s DragonCon, I decided to try something I have never done at a con. I went an entire day without picking up my camera. Now you’re saying “But Steve, you’re a photographer!” and I know that it’s a big part of what I do at conventions for ReviewSTL. Since quarantine ended last year, I came to this realization. I have been using my camera like a shield. It’s easy to bounce from one person to another, limiting our interactions to a simple “Hi, can I get your photo?” The camera has been a social crutch for me for so long that I realized I don’t even really know half of the people I call friends. So for Friday of DragonCon, I left the crutch in the room and walked on my own two feet.</p>
<p>My day started late, with the usual search for a working outlet. Not a knock on the Marriott. Every hotel has a few bad outlets here and there. I couldn’t help being amused by the fact that I had to make my oatmeal on the bathroom sink though. After a couple of rough years at DragonCon on the upper floors, we try to keep a decent stock of food in our room. You never know how long it’ll take you to go find something at the food court or a nearby restaurant.</p>
<p>The main objective for my Friday is the most impressive costume I’ve ever worn. The vault dweller is iconic. Pumat is whimsical. But Darth Malak is the first truly epic character I have embodied. Our good friend and member of the STL con family Elea (@muddywaterscosplay), spent months sewing the incredibly detailed bodysuit, crafted all of the armor pieces out of foam, and finished the 3D printed mask and collar pieces. I’ve felt powerful every time I put on this costume during test fittings. The makeup test the previous week also went well. Until now, I had yet to put all of it together.</p>
<p>Keesha was along for the ride as I feverishly attempted to make my face white. Literally any cosplayer experienced in body/face paint will tell you, white paint absolutely sucks! After about two hours of fighting my own skin, Keesha helped me paint the gray tattoos over my head. Those looked good, but the white still looked like a blotchy mess. I tried my best to clean it up, but my white makeup was gone. I just kept staring at myself in the mirror, eyes going from one skin-colored patch to another. The tattoos and smokey dark eyes were successful, but the patchy skin was ruining it. I was about two minutes from bailing into the shower before Sammie walked in.&nbsp;</p>
<p>Here’s another point where I have to express just how much we lucked out with Sammie as a roommate. Definitely the number one contender for MVP of our room at DragonCon. She is an absolute genius with makeup. Not only does she do a killer job on herself every day, but she knew exactly what to do when she saw how I looked. After about fifteen minutes with some white concealer and setting powder, Sammie completely turned my mood around. Another few minutes to get the costume on and Darth Malak was fully formed. Keesha and all my roommates were all there to witness the first few minutes of my evil Sith glory.</p>
<p>While everyone else went their separate ways, James accompanied me on my first walkabout as Malak. Our first stop was Ted’s photo studio set up on the other end of the first floor. As of writing this, I haven’t yet seen the photos. What Ted showed me on his camera though… I am ridiculously excited to see them! The biggest issue for me putting on a complicated costume like this is the inability to use a camera. It makes me feel so much better knowing great photographers like Ted and Justin are covering it. They do a much better job anyway!</p>
<p>The feeling I got when walking around as Darth Malak reminded me why I started cosplaying. Faces were filled with emotions ranging from ecstatic joy all the way to fear in my intimidating presence. I chose to commission this costume because Knights of the Old Republic is still my favorite Star Wars game and my favorite RPG of all time. It’s a beloved part of the Star Wars expanded universe and is even slated for a remake in the next few years. Darth Malak is also a costume that is rarely seen in the cosplay community. I only know of one other person that ever dresses as Malak, and most people at DragonCon had never seen one!</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" src="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220903_000102901.MP_-1024x576.jpg" alt="" class="wp-image-72413" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220903_000102901.MP_-1024x576.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220903_000102901.MP_-300x169.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220903_000102901.MP_-768x432.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220903_000102901.MP_-1536x864.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/PXL_20220903_000102901.MP_.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>I attended all three of the Star Wars cosplay meetups on Friday, including the Cosplayers of the Old Republic shoot with Christian, the main Star Wars shoot with Chris Carr and Xanvai (@xanvai.cosplay), and the Jedi vs Sith shoot on my own. During the Old Republic shoot, I was chased down by Ming Chen (@mingchen37) from Comic Book Men for a photo. This epic-level nerd gave me the most memorable moment of my time as Malak. I also walked around the Hilton and Marriott lobbies during that time, soaking up as much praise as my approval seeking soul could handle. It was an incredible experience and I will be happy to wear Darth Malak at more cons in the future. I’m already planning to wear him to Archon in early October and at C2E2 next year.</p>
<p>Unfortunately, a persistent headache was getting to me. After a thorough amount of sweating and hurting, I decided it was time to give up the Darth Malak persona and start preparing myself for another night of socializing. Rather than take a shower like I should have, I kept the Malak makeup on and wore a red undershirt with shorts. This happened to inspire a great party costume idea from Christian: Beach Vacation Malak. I already have it planned out and will absolutely be taking it to a con next year!</p>
<p>During my evening wandering, I stopped to hang out for another Wulfgar party! I say another because the night before, they had a beer pong setup for Team USA. On Friday night, they were set up as a Mario Party, with James (@jameswulfgar) as Mario, John (@whojohnquade) as Waluigi, Rachel (@simplyrayelle) as Toadette, and several other characters like Kirby and Yoshi. The night of carousing also included much needed catch up time with friends like the extremely talented photographer Eddie B. (@eddiebphotos), and the bodybuilding cosplayer Joe (@musclesuitnotneeded).&nbsp;</p>
<p>The night wound down for me at about the time everyone else was starting to get in line for the rave. After a rollercoaster of a day, Keesha and I needed some time to decompress. The looks I got, still in my Malak makeup, were pretty amusing to see while we sat out on the steps in front of the Marriott. Unfortunately, if you want quiet time away from people at DragonCon, the front steps of the Marriott during a rave line is not the best option. A hotel room on the first floor of the Marriott, however, is a great one. We had hesitations about the extra upcharge for a low-level room. The weekend proved that it was a fantastic decision. It offered much-needed relief from the craziness of DragonCon on countless occasions.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_38-1024x683.jpg" alt="" class="wp-image-72409" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_38-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_38-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_38-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_38-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_38.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p><a href="#photo-gallery">Check out our DragonCon 2022 photos</a>.</p>
<h2><strong>Saturday</strong></h2>
<p>Once again, I failed to make it to the DragonCon parade. Since I started attending the Critical Role shoots as Pumat Sol, I haven’t been able to find the time. I didn’t bring Pumat to DragonCon this year. Instead of getting up and going to take photos of the parade, I slept straight through every alarm and didn’t even open my eyes until almost noon. My incompetence mixed with my Friday as a Sith Lord inspired a need to perform my duties as a photographer. Saturday was for street clothes and taking photos!</p>
<p>The first objective was in the Marriott atrium. As anyone can see from the thousands of photos on social media, the Marriott atrium is where a ton of cosplayers will come to hang out for photos, shop talk, and revelry. I first met with Keesha for lunch and for photos of her adorable Halloween classic Wanda from WandaVision. Then came a walk around the atrium to get shots of more epic cosplayers, including Josh (@thehypnorealm) in his badass Brr-Zerker from Tiny Tina’s Wonderlands.</p>
<p>After realizing what time it was, I rushed off to the Hilton patio to find the Critical Role shoot already in progress. I immediately spotted Eddie B up on the photographer line, so I squeezed in to join him. Years past have honed this shoot into a well oiled machine. Eddie and I were thoroughly impressed with the organization. He noted some things we will certainly be adopting for the shoots up at C2E2. I hate having to miss out on being Pumat, but the oppressive sun that afternoon made me happy to leave him at home. The Critical Role meetups are always special, but it was a very memorable afternoon for two critter couples that proposed and announced to all of the surrounding people their engagements.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_94-1024x683.jpg" alt="" class="wp-image-72414" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_94-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_94-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_94-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_94-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_94.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<p>Ted and I coordinated the afternoon as a room shoot with Brittani Ginoza. Brittani was also on a mission though, a mission to give out swag. There’s a relatively new tradition at DragonCon called the “Swag n Seek”, where people will bring things to either hand out or place at specific locations for others to find. I happened to stumble into some of this swag last year, but this year we were on the look for it. It mostly came in the form of badge ribbons, which were certainly in abundance!&nbsp;</p>
<p>As Brittani got ready as Lydia, I agreed to help her with the swag bag while I took photos of passing cosplayers. I was suddenly surprised by how coordinated it was. Within moments of getting to her designated spot, people were coming up to ask if she was one of the swag bearers. While I pulled double duty as bag holder and photographer, I was given a Cosplay Handler badge ribbon. Good to know people are out there appreciating the handlers! Within a few minutes, we gathered a few more friends like Des (@desireecosplay) in her alluring Poison Ivy costume, Steve (@sksprops) representing the best foam brand in the business, and Will (@dlc_props) sporting his all leather NCR Ranger.&nbsp;</p>
<p>Once the swag was gone, Brittani, Will, and I all went up to Ted and Stormy’s room. Christian was already there with his friend Julia (@rodriguez_rendered), a talented costume designer dressed as a fierce Zabrak Sith. Sammie arrived shortly after to meet all my various friends, dressed in her killer Ivy cosplay from Soul Calibur. I assisted Ted with the lights while we shot Julia as her Sith OC, then Brittani in her Lydia wedding dress. We shot Will’s NCR Ranger and Sammie’s Ivy as well. I can’t wait to see what Ted drops in his DragonCon album. I will absolutely be sharing on Average Calamities when he releases it.</p>
<p>Later that evening, I met with most of our NC con family, including Stormy, Ted, Nathan, and Sergei, at Gus’s Fried Chicken. James met up with us just before ordering. Gus’s has become a con tradition for us because we all love spicy food and fried chicken. Unfortunately, it’s a tradition I can no longer take part in. After about 15 minutes of talking and figuring out what I wanted to order (it was a busy night and a not so great server), I discovered they fry all of their chicken in peanut oil. This wasn’t a problem for me a year ago. But since last year’s DragonCon, I developed a damn peanut allergy! It’s not life threatening, but it’s enough to give me hives. Not great to have at a con!</p>
<p>So after eating dinner at a fried chicken place and not eating the chicken, I went back into photographer mode for a while. I took another stroll down to the Hilton to see if I could get into the Last Party on Alderaan. Out on the patio, I saw the ever classic Moss and Roy (@unofficialmossandroy) hanging out off to the side of the line. It was quickly apparent that I wouldn’t be making it into that party any time within the next hour, so I went over to the party out on the patio where there was no line. On the way out of the Hilton, I also ran into another long-time DragonCon friend Rebecca (@littlelionheart.cosplay) dressed as a bloody Number Five from Umbrella Academy. She recounted the tale of winning an award for her Bunny Hutch outfit on Thursday night and that she’d be entering more competitions as the White Violin. Always great to see friends doing awesome things!</p>
<p>The rest of the night was a blur of bouncing from party to party with friends from the STL con family, including Sammie, Art, Niki, James, and the full force of the Shy Guys. I’m pretty sure I ended the weekend with Mike Carr’s Shy Guy mask. That night ended for most people with an early morning rave to dance the remaining energy out of us. I remember calling it a night earlier than the others, then entertaining them one by one as they came back for late bedtime. When I’m the most sober, I switch to con-dad mode. I just want to make sure everyone’s having a good time and makes it back to their hotel room safely.</p>
<p><a href="#photo-gallery">Check out our DragonCon 2022 photos</a>.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_137-1024x683.jpg" alt="" class="wp-image-72416" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_137-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_137-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_137-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_137-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_137.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<h2><strong>Sunday</strong></h2>
<p>Just like so many other days at DragonCon, Sunday started with lunch. The original plan was for lunch and the vendor hall. Unfortunately, the start was slow, but Sammie, James, Keesha, and I did make it to the Metro Diner for a late lunch. Rain loomed outside for the majority of the lunch, unleashing into a downpour for the tail end. We knew that we’d have to time our travel correctly if we didn’t want to get caught in it. Some people melt in the rain! Once things had settled to a mere drizzle, we made our move. </p>
<p>James led us down into the subway platform that cut a decent amount of the distance, but we came across a massive obstacle. The escalator back up the other side was out of order! We had to climb up well over a hundred stairs to get back up to street level and were still at least a block away from the AmericasMart. As we walked down the line to find the end, time ticked away. By the time we rounded the opposite side of the building to start wrapping inward for the second half of the line, Keesha and I had thrown in the towel. We would just try to do what I always do, go on Monday morning when there’s absolutely no line.&nbsp;</p>
<p>After all the walking, stairs, and eventual disappointment of not even being able to get into the vendor hall, we took a break in the quality AC of my hotel room. Eventually, I paid attention to the time and realized the Fallout shoot was about to start! I hurried to get into my bloody, dirty makeup for the vault dweller. Clearly I need a new Mehron palette. I killed the white with Malak, and now could see the bottom of the black and red swatches. Luckily I don’t need too much for my dirt, grime, and wounds. The shoot had already started by the time I left the room though.</p>
<p>This was one of those unlucky times where every line to get from one hotel to another had a line to it. Yes, you had to stand in line to get in line. For every escalator and skybridge. By the time I got to the soggy Hilton patio, the shoot was already over. Luckily the Fallout fans are a quality bunch of nerds, so there were plenty left around for photo ops. Unluckily, the overwhelming humidity completely fogged up my camera. It was almost useless for the first few minutes. As I edited the album though, I think the one fogged over shot I took, of my friend Vix’s (@vampyrvixen) vicious Legionnaire, was my best of the whole weekend! Also ran into my friend Belle in one of her many Fallout cosplays, stopping for a few photos together. I’m realizing that while we got photos taken together, I have no idea where they’ll be! </p>
<p>As the DC Cosplayers group formed up for their photoshoot, I hung out with Des in her cute badass Vault Dweller and Will in his NCR Ranger. Once Will left, it was clear we wouldn’t get much more time outside without more rain. Des and I had each heard about the boozy ice cream stand from various sources and figured it was the perfect time to try some. Daddy O&#8217;Brien&#8217;s Irish Ice Cream Pub offered several great options. We both opted for the Kentucky Salted Caramel, which was obviously the best option! This was one of those great moments at cons where I bond with a friend over something silly. Des and I sat down to watch people, catching up on life and the crazy events of the weekend. We were shocked and amused when the rain picked up again, absolutely washing out the DC shoot. Cosplayers and photographers alike all rushed inside to escape the weather while we sat there warm and dry eating boozy ice cream!</p>
<p>I walked Des back to the Hyatt so she could meet up with others, coming across our favorite photo goblin Alex (@aleestudios). Alex is a goblin because she BOOKS HER WHOLE WEEKEND. She doesn’t give herself time to just enjoy the con! I’ve gone entire events without seeing her, or only seeing her once. This was another instance. We made it count though, discussing future con plans like a potential Bastila and Darth Malak shoot with April Gloria (@_aprilgloria) at C2E2 next year. We also discussed redoing my Tenzin shoot from last year’s DragonCon at Katsucon in February. If our schedules line up, we’re absolutely making that happen! Nathan also stopped on his way through, meeting Alex as she showed off her new dice wares. She had been taking orders for her new stock while performing photoshoot after photoshoot. Alex is always hustlin! I was so happy to see her.</p>
<p>Nathan and I walked back to the Marriott to integrate ourselves back into the mass of nerd friends. Soon enough came that time of Sunday night where people start to say their goodbyes and go to sleep so they can rest for the ride home. Sunday is always the most bittersweet day at any con. You’re grateful for the time you’ve had, but sad it’s just about over. Just about everyone I know came together for one last hurrah in the Marriott Atrium. This included my good friend and former D&amp;D comrade Amber (@bodoni_italic), the expert prop builder Scott (@wildkarde), and the lovely cosplay master Amanda (@jedimanda). All great people, living it up in the great company of DragonCon.</p>
<p>I also had a chance encounter with cosplayer and makeup artist Jeanette (@xmachina) who had done seriously impressive work with a Ganondorf cosplay. She gave me some great tips on layering face paints to get a smoother finish. Definitely some things I’ll keep in mind as I work on perfecting Malak’s look! After more goodbyes with friends like Annie, Jenn, and Alan (@lukehangover), I was ready to call it a night. I was truly grateful to see those friendly faces that night, but the weekend was taking its toll. One last stop for a big group photo with the STL con family, then I was off to bed. Sammie ended up getting a few copies of the photo printed for us.</p>
<p>Restlessness got the better of me that night. I needed to get away from people. Luckily Justin and Niki were there to help wind the night down with some late night talks around the quieting con. I’m glad to know that whatever’s going on, I have some quality friends to rely on. Whether it’s having a cup of boozy ice cream, bonding over strategies in a Star Wars mobile game, or just talking out in the post-rain night air.</p>
<p><a href="#photo-gallery">Check out our DragonCon 2022 photos</a>.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_148-1024x683.jpg" alt="" class="wp-image-72419" srcset="https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_148-1024x683.jpg 1024w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_148-300x200.jpg 300w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_148-768x512.jpg 768w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_148-1536x1024.jpg 1536w, https://www.reviewstl.com/wp-content/uploads/2022/09/DragonCon2022_148.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
<h2><strong>Monday</strong></h2>
<p>Monday morning was a slow drag of packing and checkout procedures. The wait for a baggage cart is always the biggest amount of time. Understandably so when the majority of the hotel is trying to get out at the same time. I helped Keesha bring her things back to my hotel room, saying one final goodbye to the Ginoza room.&nbsp;</p>
<p>After loading up my car, we went for a walk down to the vendor hall. James accidentally lodged his badge deep into the already packed car, but he had already been to the vendor hall at least twice. He opted to go get breakfast while Keesha and I searched through the four floors of vendors. We miraculously managed not to buy anything on the first three floors, but when it came to the Artist Alley… we caved. Keesha bought up just about every Scarlet Witch print in sight. I don’t blame her though. There was some truly epic Wanda art. I grabbed a couple of Star Wars pieces for myself, including a metal Darth Maul print by Jim Mehsling (@jimmehsling). I’ve seen Jim’s booth at several cons before. His dark Star Wars scenes always impress me. I’m so glad I finally bought one of his pieces.</p>
<p>Through the blur of various vendors, we also ran into Sammie, Niki, and Christina (@maddenpants) on a shopping trip of their own to kill time before their flight. It was one of those classic “we’re too exhausted to talk, but we’re just going to say hi and bye really quick” moments that you always have on a Monday morning of DragonCon. With shiny new art in hand, we made our way back to the Marriott to meet up with James and retrieve the car. Nine hours of manic carpool karaoke later, we were back home!</p>
<p>All things considered, DragonCon 2022 was a great con. I had a rollercoaster of emotions and caught Covid, but it was still a very fun time and made for several great stories. I’m very happy to share all these memories with you. This year has inspired me to go for more ambitious cosplays. If I’m not going to do many, I might as well do them big! I’m currently kicking around ideas for a new Fallout costume as well as another big Star Wars character. I’ll be shopping the ideas around at my next couple of cons.</p>
<h2>Photo Gallery</h2>
<a id="photo-gallery"></a><div class='embedsocial-album' data-ref="b976902a4fca48c4f2013af5da94018151a4ce90"></div><script>(function(d, s, id){var js; if (d.getElementById(id)) {return;} js = d.createElement(s); js.id = id; js.src = "https://embedsocial.com/embedscript/ei.js"; d.getElementsByTagName("head")[0].appendChild(js);}(document, "script", "EmbedSocialScript"));</script>
<div id="wpdevar_comment_1" style="width:100%;text-align:left;">
<span style="padding: 10px;font-size:20px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;color:#000000;">Facebook Comments Box</span>
<div class="fb-comments" data-href="https://www.reviewstl.com/weekend-in-review-dragoncon-2022/" data-order-by="social" data-numposts="7" data-width="100%" style="display:block;"></div></div><style>#wpdevar_comment_1 span,#wpdevar_comment_1 iframe{width:100% !important;} #wpdevar_comment_1 iframe{max-height: 100% !important;}</style> </div>
</div>
</div>
<div class="col-md-4">
<div class="sidebar">
<div id="search-2" class="widget widget_search"><form class="search-form" action="https://www.reviewstl.com/">
<input type="submit" id="searchsubmit" value="" class="search-form-button" />
<input type="text" value="" name="s" id="s" class="search-form-line" placeholder="Search ..." />
</form></div><div id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-main-nav-container"><ul id="menu-main-nav-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52144"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52142"><a href="https://www.reviewstl.com/category/reviews/movie-reviews/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52143"><a href="https://www.reviewstl.com/category/reviews/live-theater-reviews/">Live Theatre</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62764"><a href="https://www.reviewstl.com/category/concerts/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62763"><a href="https://www.reviewstl.com/category/reviews/videogame-reviews/">Videogames</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52255"><a href="/event/">STL Events</a></li>
</ul></div></div><div id="text-3" class="widget widget_text"> <div class="textwidget"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ur1&category=dvd&banner=0GPYG7RE5B833WVRM7G2&f=ifr&linkID=2ddaad28b4519517123b82ef295796be&t=revstl-20&tracking_id=revstl-20" width="300px" height="250px" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div>
</div><div id="text-4" class="widget widget_text"> <div class="textwidget"><br>&nbsp;<br><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=49&l=ur1&category=entcollect&banner=1AY9YEY02VKRHRHZ9M02&f=ifr&linkID=aa5284c0f37af74bb64e45e48cc85a50&t=revstl-20&tracking_id=revstl-20" width="300px" height="600px" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div>
</div>
</div>
</div>
</div>
</div>
</div>


<div class="footer">
<div class="container">
<div class="col-md-4">
</div>
<div class="col-md-6">
</div>
<div class="col-md-2">
</div>
</div>
<div class="footer-copyright">
&copy; 2018 Review St. Louis. All rights reserved.
</div>
</div>

<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v13.0&appId=409213959110159&autoLogAppEvents=1"></script>
<script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='29c73300ad926900bc4bfd00e62d7e000518380099d4400048e7ec0068931600';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">
      var ajaxurl = "https://www.reviewstl.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><link rel='stylesheet' id='thickbox-css' href='https://www.reviewstl.com/wp-includes/js/thickbox/thickbox.css?ver=6.0.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/plugins/embedpress/assets/js/front.js?ver=3.5.0' id='embedpress-front-js'></script>
<script type='text/javascript' id='subscription-js-extra'>
/* <![CDATA[ */
var ttSubscrConfig = {"error_class":"error","required_class":"required_error","required_msg":"Please fill required fields","invalid_email_class":"invalid_email","invalid_email_msg":"Invalid Email","input_timeout":"1","success_class":"success","animation_done_class":"animation_done","result_timeout":"3000","result_container_selector":"","date_format":"F j, Y, g:i a","date_headline":"Date","no_data_posted":"No data received","error_open_create_files_msg":"","success_msg":"Succesfully Subscribed","error_writing_msg":"Couldn't write to file","error_mailchimp":"","subscription_nonce":"1580349780"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty/tesla_framework/static/js/subscription.js?ver=6.0.2' id='subscription-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/retina-1.1.0.min.js' id='novelty-js-retina-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/modernizr.custom.63321.js' id='novelty-js-modernizr-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/bootstrap.js' id='novelty-js-bootstrap-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/placeholder.js' id='novelty-js-placeholder-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/imagesloaded.pkgd.min.js' id='novelty-js-imagesloaded-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/masonry.pkgd.js' id='novelty-js-masonry-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/plugins.js?ver=1.01' id='novelty-js-plugins-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/jquery.swipebox.min.js' id='novelty-js-swipebox-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/buttons.js' id='novelty-js-sharethis-js'></script>
<script type='text/javascript' id='novelty-js-options-js-extra'>
/* <![CDATA[ */
var novelty = {"ajaxurl":"https:\/\/www.reviewstl.com\/wp-admin\/admin-ajax.php","contact_fill":"Please fill in all the required fields.","contact_email":"Please provide a valid e-mail."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/themes/novelty-child/js/options.js' id='novelty-js-options-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=14.1.2' id='__ytprefsfitvids__-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.reviewstl.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.reviewstl.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<!--[if lt IE 9]><script src=""></script><![endif]-->
</body>
</html>










